Intellisense fix for Visual Studio 2008 ASP.Net pages

Somehow my settings got jacked up on VS 2008 and Intellisense didn’t work when viewing editing aspx pages in “source” mode (when you’re editing HTML and web form tags).  It coulda been a service pack install, it coulda been some of the paranoid junk that corporate America loads onto work computers nowdays, but regardless of the cause I was hosed.  I tried everything.

I finally found a post that led me to an answer while looking digging through the offical ASP.Net forums.  The proposed fix on the forum didn’t solve my particular issue (the topic was intellisense in XML files), but one poster mentioned switching the editor by right-clicking and selecting “Open with…”.  I remembered seeing that and tried out a couple of different editing modes.  It turns out that the “Web Form Editor” is the one to use.  I set that mother as my default and now I’m plugging away at aspx pages again.

Soooo…in VS 2008’s Solution Explorer, right-click on an aspx page you’d like to edit, then select “Open with…”.  Choose “Web Form Editor” and click the “Set As Default” button.  Done.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: